Results 1 to 3 of 3

Thread: Using the Digitech Jamman Looper live- why does it feedback?

  1. #1
    Join Date
    Sep 2011
    Posts
    2
    Post Thanks / Like

    Default Using the Digitech Jamman Looper live- why does it feedback?

    Does anyone know the best way to set up the Digitech looper live? I had a mic and my electric guitar plugged into the looper and then I had the looper plugged into the board of a PA. With each loop I added during my show I kept getting more and more feedback. I'm assuming its because the mic was also looping the sound from the PA, ontop of what I was playing.

    How do I avoid this? I've seen great loop artists like Andrew Bird and Merril Garbus pull this off without a hitch. What am I doing wrong?

    Should I be connecting the loop pedal to an Amp and then mic the amp? Is it a matter of setting the levels? Is it the mic?

    I'm lost.

    Denise

  2. #2
    Join Date
    Dec 2005
    Location
    Idaho (I-duh-ho)
    Posts
    12,593
    Post Thanks / Like

    Default

    Once the mic starts feeding back then you end up looping that and you end up with way too much feedback sound.

    You'll need to reduce the gain on your mic so that it won't feedback either in the mains or monitors. Lots of people use the same setup with good results. You are going to have to do some experimenting to get the sound under control. There isn't much a sound man can do because you are sending him the signal from the looper and it's already feeding back from that point. If he uses eq or turns the channel down he'll also turn your guitar down and eq the guitar. Don't have the mic gain up so high that the mic is super sensitive and picks up everything. You just want the instrument (voice, acoustic instrument) to come through the mic.

    Good luck.

    "No Tele For you." - The Tele Nazi

    Ha! Tele-ish now inbound.

  3. #3
    Join Date
    Jun 2008
    Location
    Down Under
    Posts
    1,711
    Post Thanks / Like

    Default

    Nice work Spud, I was typing away and then saw your response. I've not used any of my loopers with a mic (yet) so I've not experienced this particular issue, but I'm curious to hear what works so I know how to tackle it if I find myself in the same predicament.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •